Terraform : 'Resource state' bloqué par un verrou fantôme

bernier-andre 23/02/2026
RÉSOLU

yo, j'ai eu un crash pendant un apply. Maintenant, Terraform me dit Error acquiring the state lock. Je suis tout seul sur le projet, y'a personne d'autre qui lock le state.

23/02/2026 à 19:30

3 commentaires

yrodrigues
Membre Actif Secouriste
Avatar de yrodrigues
yrodrigues
Membre Actif Secouriste

Si ton backend est sur S3, va dans ta table DynamoDB de lock et supprime l'entrée manuellement. C'est l'ID de session du crash qui est resté.

Modifié le 23/05/2026 à 16:20

Plus propre : utilise la commande terraform force-unlock <lock_id> avec l'id que terraform t'affiche dans l'erreur. ça évite d'aller bidouiller la db à la main.

25/02/2026 à 12:21

Le force-unlock a marché direct. Je connaissais pas cette commande, c'est propre. Thx !

26/02/2026 à 11:45

Laisser une réponse

Vous devez être connecté pour poster un message !

Rejoindre la communauté

Recevoir les derniers articles gratuitement en créant un compte !

S'inscrire
An Error Occurred: Internal Server Error

Oops! An Error Occurred

The server returned a "500 Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.