serveur linux iowait de l'enfer sur une partition

michel57 10/03/2026
RÉSOLU
michel57
Auteur Actif
Avatar de michel57
michel57
Auteur Actif

salut

on a un serveur linux (debian 11 kernel 5.10) qui a des problèmes de iowait énorme sur une seule partition /dev/sdb1. l'appli dessus est super lente. j'ai checké les logs, pas d'erreurs disque. c'est quoi le truc avec le iowait ?

# iostat -x 1
device            r/s     w/s     rkb/s     wkb/s   rrqm/s   wrqm/s  %rrqm  %wrqm  aqu-sz  await  %util
sdb              0.00  100.00      0.00  1000.00     0.00     0.00   0.00   0.00   50.00  500.00 100.00

le %util est à 100% mais c'est surtout le await qui m'inquiète

10/03/2026 à 00:10

5 commentaires

louis-alex
Membre
Avatar de louis-alex
louis-alex
Membre

yo. 500ms d'await c'est pas normal pour sdb. as-tu regardé les dmesg pour des erreurs liées au disque ou au contrôleur raid ? des fois c'est un disque qui lâche silencieusement

10/03/2026 à 19:20
benjamin-mace
Membre Actif
Avatar de benjamin-mace
benjamin-mace
Membre Actif

regarde aussi ce que fstrim -v /montpoint dit. si le disque est un ssd ça peut être le trim qui pose problème ou si c'est un disque "mécanique" est-ce qu'il y a des écritures séquentielles ou aléatoires ? un vmstat 1 5 peut donner des infos sur le type d'io

11/03/2026 à 15:03
navarro-eleonore
Membre Actif
Avatar de navarro-eleonore
navarro-eleonore
Membre Actif

et le scheduler io ? c'est cfq ou mq-deadline ou none ? tu peux voir ça avec cat /sys/block/sdb/queue/scheduler. si c'est un ssd met none ou mq-deadline

12/03/2026 à 13:46

as-tu un lsof +l1 pour voir quels process écrivent sur cette partition ? des fois une appli qui fait des sync() à gogo ou des gros flushs peut plomber le disque sans erreur apparente. et verifie le smartctl du disque, c'est le premier truc à faire pour un disque qui rame

13/03/2026 à 12:50
michel57
Auteur Actif
Avatar de michel57
michel57
Auteur Actif

merci pour toutes les pistes ! après un smartctl -a /dev/sdb j'ai un reallocated_sector_ct qui est passé de 0 à 500. c clairement le disque qui est en train de mourir. on va le remplacer. je pensais que dmesg allait m'alerter direct. thx la team !

14/03/2026 à 11:51

Laisser une réponse

Vous devez être connecté pour poster un message !

Rejoindre la communauté

Recevoir les derniers articles gratuitement en créant un compte !

S'inscrire
An Error Occurred: Internal Server Error

Oops! An Error Occurred

The server returned a "500 Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.