Docker : Erreur 'X509: certificate signed by unknown authority'

adrienne-martin 14/09/2025
RÉSOLU

yo, j'ai un registry privé avec un certificat auto-signé. j'arrive à me loguer mais dès que je tente un docker pull, le daemon refuse la connexion pour raison de sécu.

14/09/2025 à 06:08

2 commentaires

mchevallier
Membre
Avatar de mchevallier
mchevallier
Membre

crée le dossier /etc/docker/certs.d/ton-registry.com/ et colle ton fichier ca.crt dedans. ensuite restart docker. c'est plus propre que de mettre le registry en insecure-registries dans le daemon.json.

Modifié le 23/05/2026 à 16:20

certificat copié dans certs.d, plus besoin de bypasser la sécu, ça pull nickel. merci !

16/09/2025 à 19:40

Laisser une réponse

Vous devez être connecté pour poster un message !

Rejoindre la communauté

Recevoir les derniers articles gratuitement en créant un compte !

S'inscrire
An Error Occurred: Internal Server Error

Oops! An Error Occurred

The server returned a "500 Internal Server Error".

Something is broken. Please let us know what you were doing when this error occurred. We will fix it as soon as possible. Sorry for any inconvenience caused.